'책'에 해당되는 글 16건

와이어샤크를 활용한 실전 패킷 분석 개정판(에이콘출판)

* IT/Network







와이어샤크를 활용한 실전 패킷 분석                                                                     에이콘

크리스 샌더즈(chris sanders)

상황별 시나리오에 따른 해킹 탐지와 네트워크 모니터링





와이어샤크에 관한 활용 책이다. 

와이어샤크라는 부분을 책제목에 사용하는 것만큼 와이어샤크에 대한 주요한 내용을 다루는 것 같아서 보게 되었다.

그만큼 와이어샤크가 네트워크패킷분석의 중요한 툴이 되었고, 실전에 사용하는 방법 역시 필요하기에 책까지 나오게 된 것 같다.

이 책에서는 필터링 방법과 설명에 대해 자세히 나와있었다. 

다른 패킷분석책에서 다룬 적이 없던 그래프와 보안 무선 등.. 신기하였다. 그런만큼 더 어려워지고 실무용이였던 부분의 책이었다.

그리고 여러가지 주요한 내용을 다루었다. 


보안패킷분석,무선패킷분석,와이어샤크 고급기능,일반 프로토콜 상위/하위 를 다루었다.

아무래도 여러가지 추가기능,무선과 보안에는 항상 새로운 기술이 나오고 중요한 기능이므로, 개정판을 쓴 것 같기도 하다.

네트워크패킷 책을 연계적으로 보게되니 비슷한 부분과 겹치는 부분이 있다. 당연하다고 생각하고 그 만큼 중요한 부분이라 생각한다.


이 책에서 조금 아쉬웠던 부분은 그림 7-15 이렇게 표시를 하기는 하지만, 글은 정말 길게 설명이 되어있는데 그 그림자체는 뒷장에 있는 경우가 많았던 것 같다. 그런 부분에서는 아쉬웠고, 조금 보기에는 불편하면서도 헤깔리기도 하였다.

아무래도 번역과 그림의 적절한 위치 선정에 장애가 있어 그럴 것이라고 생각되지만 읽는 입장에서는 아쉬웠던 부분이었습니다.





YES24 : 와이어샤크를 활용한 실전 패킷 분석 개정판


개정판(2012)이여서 원래나온 책(2007)보다 비싼 것 같다.



Name
Password
Homepage
Secret

security 네트워크 패킷 포렌식 (SECUBOOK)

* IT/Network






security 네트워크 패킷 포렌식                                                 SUCUBOOK

최경철(IT산업종사자)저






2012년 07월 31일에 발행된 네트워크패킷 포렌식 책이고, 네트워크 파트에 대해 깊게 알아보려고 도서관에서 빌려 보았다.


책소개 : 네트워크 패킷분석에 필요한 TCP/IP 관련 기본기술을 소개하여 패킷분석을 위한 기본기를 쌓을 수 있으며 와이어샤크의 설치 및 동작방식에 대한 기본개념과 와이어샤크의 저장포맷인 PCAP 의 숨겨진 의미를 파악해 볼 수 있다.


솔직히 이 책을 보면서 느낀 것은 꼭 책을 사서 읽고 싶을 정도로 좋은 책이었다.

왜냐하면 기초적인 네트워크파트를 한번 설명해주고, 와이어샤크에 대해 깊게 설명하기 때문이다.

와이어샤크 사용법은 약간씩만 알고 있었지만, 이 책을 통해서 더욱 깊이 알게 된 것 같다.





목차


1. TCP/IP 개념
2. 와이어샤크 및 PCAP 포맷
3. Raw 패킷분석
4 FTP 패킷분석 
5. Telnet 패킷분석
6. 파일 Magic Number
7. HTTP 컨텐츠분석
8. 포트 587번의 정체
9. 포트스캔 패킷분석
10. JAR Launcher 패킷분석
11. 백도어 패킷분석
12. 자바애플릿 악성코드 패킷분석
13. 쉘코드 패킷분석(1)
14. 쉘코드 패킷분석(2)
15. 악성코드 패킷분석
16. 웹해킹 패킷분석
17. 무선 패킷분석
18. DoS공격 패킷분석
19. Tcpdump 및 Ngrep 데이터호환
20. 와이어샤크 구현
21. 부록



여기서 12~15,19,20챕터는 제대로 이해하지 못했다. 기초적인 부분이상을 요구하는 고급파트인 것 같다. 

쉘코드는 공부한 적이 없고, 자바 애플릿은 자바는 알지만 여기저기 연동되고 하다보니 헤깔려서 어렵게 느껴졌다.

악성코드 패킷분석 부분은 약간의 다른 필수적 지식요소가 필요했던 것 같다.

와이어샤크 구현은 아직.. 나에게는 먼 길인 듯한 느낌이..

조금 더 공부해서 확실히 알아내고야 말겠다!!


나머지 챕터는 와이어샤크를 실습하면서 직접 간단히 기초적으로 할 수 있는 부분 같다. 해보니까 대체적으로 할만했고, 이런 부분들을 새롭게 알게 되어서 뿌듯하기도 하다.


Magic number 부분은 신기하기도 했다. 이건 뭔데 PK..(오피스와 zip 파일 등..)와 MZ(?).. 빼고 나머지를 삭제하는 걸까? 하는 부분..알고나니 자체적으로 정의를 한 것이여서 그런 것이라 신기하기도 했다.

587포트 부분도 신기했고, 책을 한번 돌려보는 것보다 두세번 돌려보니 정확히 알게되고 궁금했던 부분도 다시 이해하게 되는 것 같다.






YES24 : security 네트워크 패킷 포렌식(SECUBOOK)


한번 책을 사서 읽어보시는 것을 추천드립니다!




Name
Password
Homepage
Secret

해킹과 보안(영진닷컴)

* IT







해킹과 보안 (Hacking & Security)

영진닷컴                                                      김승현,윤청원 공저

해킹을 알면 보안이 보인다 




이번에 소개할 책은 해킹과 보안 이라는 책 입니다.

최신의 책은 아니지만 기초적인 내용과 전반적 보안기술들을 익힐 수 있는 좋은 서적인 것 같다.

몰랐던 내용도 나오기도 하고, 유용한 정보들이 꽤 많이 들어있는 것 같다.

전체적으로 해킹과보안에 기초를 다질 수 있는 내용이 주로 담겨있습니다.


- 1장에는 기초적인 컴퓨터 전산 지식(역사,역대 해커 소개 등..)

- 2장에는 기본적인 해킹이나 보안의 정보수집

- 3장~8장에는 windows 95/98/xp,트로이목마  등.. 공격을 통한 보안내용






읽으면서 느낀 점은 내가 모르는 부분도 많았던 것 같고, 기초를 더 확실히 다지게 되는 계기가 된 것 같다. 한번 책사서 간편히 읽어보는 것도 나쁘지 않다는 의견이다.


링크 : YES24(해킹과보안)






Name
Password
Homepage
Secret

사랑에 관한 3가지 관점 - 김지윤 소장(좋은연애연구소)

* Twodragon/잡담 (Chat)








오늘 페이스북을 통해 김지윤 소장님을 알게 되었다.

처음엔 이것이 무엇인가? 하는 마음으로 바라보았다. 그러나 정말로 재밌게 강연을 하시는 것이다.

기독교인이기때문에 기독교와 관련을 지어서 많은 이야기를 하지만, 정말정말 재밌고 좋은 말씀을 많이 하신다.

그리고 사랑에 대해 알려주셔서 너무 재밌었다.  독교인들이 많이 말하는 자매와 형제로 말씀을 남자와 여자에 대해 말을 해주셔서 뭔가 친근한 말투가 있다. 또한 남자와 여자의 차이에 대해 ex 를 들어서 해주시니 바로 와닿았다.


일단 맨 밑의 영상을 틀어서 영상을 귀로 들으면서, 글들을 읽으면서 공감을 하셨으면 좋겠다.


너무너무 좋은 말들도 많고, 정말 모두가 이런 생각을 가졌으면 좋겠다. 건전한 성으로 받아들이면서, 

사람의 눈을 낮추면서 자신을 사랑해주는 서로의 남녀가 만나는 것이 좋다는 것이라는 거다.







사진이 많이 없네요..



김지윤 기독교인
소속
좋은연애연구소 (소장)
경력
좋은연애연구소 소장
한국기독학생회 IVF 간사



간단한 소개이다. 그리고 책을 쓰셨는데, 

사랑하기 좋은 날/고백하기 좋은 날을 쓰셨다. 꼭 한번 사서 읽어봤으면 좋겠다. (영상을 보고 나서 이 분에 대해 궁금하여 책을 읽거나 이 분의 글을 읽음으로써 더욱 교양이 쌓일 것 같아서 사야겠다는 생각이 들었다.)




링크 : YES24(사랑하기 좋은 날)



(네이버 검색에서도 알 수 있듯이 제일 싸게 구입할 수 있는 인터넷 도서이다. 내 생각으로는 교보문고 다른 곳도 많이 있지만, 네이버 적립금사용까지 가능하면서 적립도 되고, 인터넷 택배무료배송, 가장 값싼 책값이다.)



링크 : YES24(고백하기 좋은 날)








사랑에 관한 3가지 관점 - 김지윤 소장


여기에 대한 줄거리를 간단히 말해보려고 한다.

사랑에 관해서 적은 항상 자기자신, 자신의 내부에 있다고 한다.

3가지 관점에 대해 말하는데, 이 중 내면의 상처의 연약함, 결혼에 관한 세속적 가치관, 포기하지 못하거나 잘못된 기준

 


파란글은 제가 영상을 보면서 즐겁게 들었고, 정확히 이 부분이 재밌었고, 저한테는 가장 좋았던 부분입니다.




※ 여자분들에게 전해드리고 싶은 말


- 원하는 이상형의 조건이 너무 많다.

- 완벽한 이상형의 백마탄 왕자님은 말을 타다 죽었기 때문에 오지 않는다.

- 무지개 너머에 있는 왕자님은 무지개 너머의 공주님하고 만난다.

- 아우디를 타는 것 보다 음식물쓰레기를 버리지 않는게 성공한 결혼이다.

- 솔직함이란 모든것을 이야기 하는것이 아니라 진실을 이야기 할 때 거짓을 말하지 않는 것이라 했습니다.

- 왜? 라는 질문을 공론화 시켜서 둘 사이에서 해야 한다 : 당사자가 아닌 친구들에게 물으면 안된다.

- Boundary : 사귀지 않을거면 Boundary를 지키고 돌아가야 한다.  그렇지 않으면 문란해진다.

- 공감을 아닌 감당할 수 있는 사람을 찾아야 한다.

- 로맨스 영화가 아닌 가족 다큐를 찍을 수 있는 사람을 만나야 한다.

- 운명적인 짝은 없다. 

- 결혼은 가장 사랑하는 사람과 하는게 아니라 가장 타이밍이 맞는 사람과 하는 것

 ( 가장 맛있는 라면은 남이 끓인 라면을 한 젓 가락만 얻어 먹을때, 무슨 라면이었느냐는 중요한게 아니라 라면을 먹은 상황에 달려 있다)

- 남자들이 원하는 여자 : 응원단장, 연인, 엄마, 가장친한친구, 동물조련사



※ 남자분들에게 전해드리고 싶은 말


- 정직에 대한 강박 관념 버리기

- 대화의 중요성

- 이미지에 속으면 안된다.

- 여성이 남성에게 바라는 필요 : 놀이친구, 영웅(필요할때 옆에 있어주는 것), 연인(외모가 아니라 정서적인것, 존중받고 정서적인 것), 
 우정을 나눌친구

- 쇼핑을 할때 고른 물건에 대해서 "어때?" 라고 물어볼때, 대답은 중요하지 않다. 어차피 자신이 마음에 드는 것을 산다.

살짝 생각하고 고민하는 척(?)을 하고 "이쁘다" 라고 하면 된다. 같이 쇼핑을 하는 것을 즐거워 하고 있는가를 중요시 한다.

- 모든 여자와 대화할수 있는 매직키워드 4개 : 진짜, 정말이야, 웬일이야, 헐

( Ex : 신도림역에서 영숙이 1:21:00 ~ )

- 가끔 그녀의 뒷말을 따라할 것.

- 소개팅일 경우에는 존댓말로만 바꾸면 됨.

- 좋은 남자와 여자는 만나는 것에 익숙하지 못한다. 그리고 개성이 있지 않고, 매력적이지 않다.

- 왜냐면 그녀에게 중요한 것은 이성적인 것이 아니라 소통, 공감해주는 것이기 때문

- 우리가 논리적일때는 싸울때 우리의 일상은 비논리, 의미, 공감, 경청




※ 결혼을 할 것인가


- 세상이 정의하는 결혼 : 결혼은 희생과 헌신을 위해 하는 것이라기 보다는 안정과 보다 나은 행복을 위해서 하는 것이다. 경제적인 풍요와 매력적이고 완벽한 이상형의 배우자는 행복한 결혼 생활의 필수 조건이다.

- 결혼에서 원하는 것 3가지 

1) 행복 : 결혼자체가 행복을 주는 매직스페이스가 아니다. 좋은 학교, 좋은 직장에 들어갔다고 해서 행복이 주어지지 않는다. 결혼을 했다고 행복이 주어지지 않고 사랑의 수고를 해야만 행복의 열매가 생긴다.

2) 안정 : 결혼하면 허니문푸어, 애를 낳으면 베이비푸어

3) 로맨스 : 당장 로맨스를 즐기려면 결혼이 아닌 연애를 해라. 진정한 로맨스는 15년간 깊은 갈등을 찍은 부부에게 찾아오는 선물 같은 것이다.


- 동화의 해피엔딩에 속지마라

그 후 행복하게 살았다는 말은 문학에 나오는 가장 비극적인 문장 가운데 하나이다.


- 실제의 결혼생활 : 결혼은 단단히 각오를 하고 희생을 하겠다는 마음으로 시작해야 한다.

1) 35,000 번의 식사 준비

2) 10,000 ~ 40,000 이부자리 정리

3) 7,000 번의 화장실 청소

4) 기저귀 2년 기준으로 4,320~8,640

5) 수유 1년 기준 1,822~3,600


- 가장 고급스러운 결혼

 가장 고급스러운 결혼이란 심리적인 성장을 극대화하는 결혼이다. 아내, 남편, 아이들 서로가 선한 영향력을 주고 받으면서 함께 비슷한 속도로, 긍정적으로 진화하는 결혼 생활을 말한다.










사랑에 관한 3가지 관점 - 김지윤 소장(1시간 30분정도의 영상이다.)

좋은연애연구소 USTORY




BlogIcon ㅉㅉ 2015.06.05 12:51 URL EDIT REPLY
개나소나 기독교인
BlogIcon 박진태 2015.06.14 23:33 URL EDIT REPLY
김지윤씨 하나님에자녀로 귀하게 사명잘감당하고 계세요 주의이름으로 사랑합니다
Name
Password
Homepage
Secret

네트워크 관리사 1,2급 필기(기출문제/요약/팁/후기)

* IT/자격증







네트워크관리사 1,2급 필기




위 책은 공식 네트워크 관리사 시험보시는 분들의 베스트 셀러 입니다. 기본지식이나 서적이 필요하시면 사시는 것이 좋습니다.


링크 : YES24(네트워크관리사 1,2급)


교보문고, 11번가 역시 싸고 좋지만, 네이버 검색을 해보시면 아시다시피 가격 비교를 보시면 제일 쌉니다. 아마 처음하시는 분들과 오래하신분들도 자격증이론은 틀리기때문에 사시는 것을 추천합니다.





네트워크 관리사 2급 필기 후기


네트워크 관리사 2급시험을 보았습니다. 인천에 있는 부평근처에서 보았습니다. 어떤 IT 학원(?)이였던 것 같았습니다.

시험은 70점을 맞았고, 합격을 하였습니다. 네트워크 관리사 2급 필기 시험을 2013.01.27일날 시험을 보았네요.

거의 1주일 전부터 떨어지면 안된다는 생각으로 엄청 공부하였습니다. 

책을 사서 이론을 보면서 옆에 딸린 문제들이 많더군요.. 위 책은.. 그래서 그 부분때문에 몇점정도 더 맞아서 커트라인 60점을 넘긴 것 같네요



일단 기출문제는 문제은행식입니다. 그렇지만 문제 은행식이여도 시험에서는 60% 정도도 밖에 안나온다고 생각합니다.

그렇기 때문에 문제를 풀면서 이론을 같이 봐주어야한다고 생각합니다.


그리고 네트워크 관리사 2급을 따야하는 이유는 저는 학점은행제를 하고 있기 때문에 학점 14학점이 필요하기 때문에 취득할려고 합니다.

학점은행제에서 전공 자격증 14학점으로 들어가니 취득하시면 이득이 될꺼라고 생각합니다.



링크 : 네트워크 관리사 2급 기출문제 CBT



Name
Password
Homepage
Secret

CCNP Switch 642-813 정리(ccnp switch/ccnp)

* IT/자격증






CCNPSwitch 642-813 Official Certification Guide [With CDROM]

 



링크 : 반디앤루니스



자주 이용하는 반디앤루니스 인터넷 서점입니다. 네이버 마일리지까지 적립되고 사용가능하기 떄문에 더욱 싸게 살 수도 있습니다.

교보문고, 11번가 역시 싸고 좋지만, 네이버 검색을 해보시면 아시다시피 반디앤루니스가 무료배송인데다가, 가격 비교를 보시면 제일 쌉니다. 아마 처음하시는 분들과 오래하신분들도 자격증이론은 틀리기때문에 사시는 것을 추천합니다.


더보기



CCNP 에 대해 자세하고 정확히 알고 싶으면 가이드 북 다운받을 곳은 많으므로 잘 찾아보도록 한다.

시험이 1~2주정도 남았을 때는 되도록 안보는 게 낫다고 권장합니다.

왜냐하면 덤프와 시뮬을 보기에도 바쁘기 때문입니다.


AAAdot1x Lab Sim



Acme is a small shipping company that has an existing enterprise network comprised of 2 switches;DSW1 and ASW1. The topology diagram indicates their layer 2 mapping. VLAN 40 is a new VLAN that will be used to provide the shipping personnel access to the server. For security reasons, it is necessary to restrict access to VLAN 20 in the following manner:
– Users connecting to ASW1’s port must be authenticate before they are given access to the network. Authentication is to be done via a Radius server:
– Radius server host: 172.120.39.46
– Radius key: rad123
– Authentication should be implemented as close to the host device possible.
– Devices on VLAN 20 are restricted to in the address range of 172.120.40.0/24.
– Packets from devices in the address range of 172.120.40.0/24 should be passed on VLAN 20.
– Packets from devices in any other address range should be dropped on VLAN 20.
– Filtering should be implemented as close to the server farm as possible.
The Radius server and application servers will be installed at a future date. You have been tasked with implementing the above access control as a pre-condition to installing the servers. You must use the available IOS switch features.


ASW1(config)#aaa new-model

ASW1(config)#radius-server host 172.120.39.46 key rad123

ASW1(config)#aaa authentication dot1x default group radius

ASW1(config)#dot1x system-auth-control

ASW1(config)#interface fastEthernet 0/1
ASW1(config-if)#switchport mode access
ASW1(config-if)#dot1x port-control auto

ASW1(config-if)#exit

ASW1#copy running-config startup-config

2) Configure DSW1:


DSW1(config)#ip access-list standard 10 
DSW1(config-std-nacl)#permit 172.120.40.0 0.0.0.255
DSW1(config-std-nacl)#exit

DSW1(config)#vlan access-map MYACCMAP 10 
DSW1(config-access-map)#match ip address 10
DSW1(config-access-map)#action forward
DSW1(config-access-map)#exit

DSW1(config)#vlan access-map MYACCMAP 20
DSW1(config-access-map)#action drop 
DSW1(config-access-map)#exit

DSW1(config)#vlan filter MYACCMAP vlan-list 20 

DSW1#copy running-config startup-config




MLS and EIGRP Sim


You have been tasked with configuring multilayer SwitchC, which has a partial configuration and has been attached to RouterC as shown in the topology diagram.

You need to configure SwitchC so that Hosts H1 and H2 can successful ping the server S1. Also SwitchC needs to be able to ping server S1. Due to administrative restrictions and requirements you should not add/delete VLANs, changes VLAN port assignments or create trunk links. Company policies forbid the use of static or default routing. All routes must be learned via EIGRP 650 routing protocol.

You do not have access to RouterC, RouterC is correctly configured. No trunking has been configured on RouterC.
Routed interfaces should use the lowest host on a subnet when possible. The following subnets are available to implement this solution:
– 10.10.10.0/24 
– 190.200.250.32/27 
– 190.200.250.64/27
Hosts H1 and H2 are configured with the correct IP address and default gateway.
SwitchC uses Cisco as the enable password.
Routing must only be enabled for the specific subnets shown in the diagram.

In real life, there are two ways to configure interVLAN routing in this case:

+ Use RouterC as a “router on a stick” and SwitchC as a pure Layer2 switch. Trunking must be established between RouterC and SwitchC.
+ Only use SwitchC for interVLAN routing without using RouterC, SwitchC should be configured as a Layer 3 switch (which supports ip routing function as a router). No trunking requires.

The question clearly states “No trunking has been configured on RouterC” so RouterC does not contribute to interVLAN routing of hosts H1 & H2 -> SwitchC must be configured as a Layer 3 switch with SVIs for interVLAN routing.

We should check the default gateways on H1 & H2. Click on H1 and H2 and type the “ipconfig” command to get their default gateways.

Answer and Explanation:

SwitchC# configure terminal
SwitchC(config)# int gi0/1
SwitchC(config-if)#no switchport -> without using this command, the simulator does not let you assign IP address on Gi0/1 interface.
SwitchC(config-if)# ip address 10.10.10.2 255.255.255.0 ->RouterC has used IP 10.10.10.1 so this is the lowest usable IP address.
SwitchC(config-if)# no shutdown
SwitchC(config-if)# exit
SwitchC(config)# int vlan 2
SwitchC(config-if)# ip address 190.200.250.33 255.255.255.224
SwitchC(config-if)# no shutdown
SwitchC(config-if)# int vlan 3
SwitchC(config-if)# ip address 190.200.250.65 255.255.255.224
SwitchC(config-if)# no shutdown
SwitchC(config-if)#exit
SwitchC(config)# ip routing (Notice: MLS will not work without this command)
SwitchC(config)# router eigrp 650
SwitchC(config-router)# network 10.10.10.0 0.0.0.255
SwitchC(config-router)# network 190.200.250.32 0.0.0.31
SwitchC(config-router)# network 190.200.250.64 0.0.0.31





LACP and STP Sim



RouterA is currently configured correctly and is providing the routing function for devices on SwitchA and SwitchB. SwitchA is currently configured correctly, but will need to be modified to support the addition of SwitchB. SwitchB has a minimal configuration. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.

Configuration Requirements for SwitchA

- The VTP and STP configuration modes on SwitchA should not be modified. 
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.

Configuration Requirements for SwitchB

- Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchA.
– SwitchB must operate in the same spanning tree mode as SwitchA.
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.

Inter-switch Connectivity Configuration Requirements:

- For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.


Answer and Explanation:

Below is a good solution commented by Ruci. Please say thank to Ruci!

SW-A (close to router)
SW-A#configure terminal

SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

SW-A(config)#vlan 21
SW-A(config-vlan)#name Marketing
SW-A(config-vlan)#exit

SW-A(config)#vlan 22
SW-A(config-vlan)#name Sales
SW-A(config-vlan)#exit

SW-A(config)#vlan 23
SW-A(config-vlan)#name Engineering
SW-A(config-vlan)#exit
SW-A(config)#interface range Fa0/3 – 4
SW-A(config-if-range)#no switchport mode access
SW-A(config-if-range)#no switchport access vlan 98 (These two commands must be deleted to form a trunking link)
SW-A(config-if-range)#switchport trunk encapsulation dot1q (cannot issued this command on this switch, but don’t worry coz I still got 100%)
SW-A(config-if-range)#switchport mode trunk
SW-A(config-if-range)#switchport trunk native vlan 99
SW-A(config-if-range)#switchport trunk allowed vlan 1,21-23
SW-A(config-if-range)#channel-group 1 mode active
SW-A(config-if-range)#channel-protocol lacp
SW-A(config-if-range)#no shutdown
SW-A(config-if-range)#end

——————————————————————————————–

SW-B (far from router)
SW-B#configure terminal

SW-B(config)#vlan 21
SW-B(config-vlan)#name Marketing
SW-B(config-vlan)#exit

SW-B(config)#vlan 22
SW-B(config-vlan)#name Sales
SW-B(config-vlan)#exit

SW-B(config)#vlan 23
SW-B(config-vlan)#name Engineering
SW-B(config-vlan)#exit
SW-B(config)#vlan 99
SW-B(config-vlan)#name TrunkNative // not necessary to name it but just name it same as SwitchA
SW-B(config-vlan)#exit
SW-B(config)#interface range Fa0/9 – 10
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 21
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range Fa0/13 – 14
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 22
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range Fa0/15 – 16
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 23
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#vtp mode transparent

SW-B(config)#spanning-tree mode rapid-pvst

SW-B(config)#ip default-gateway 192.168.1.1 (you can get this IP from SW-A with command show cdp neighbour detail) // not sure about this command because the question says “No routing is to be configured on SwitchB”.

SW-B(config)#interface vlan 1
SW-B(config-if)#ip address 192.168.1.11 255.255.255.0
SW-B(config-if)#no shutdown
SW-B(config-if)#exit

SW-B(config)#interface range Fa0/3 – 4
SW-B(config-if-range)#switchport trunk encapsulation dot1q (yes I can issued this command on this switch)
SW-B(config-if-range)#switchport mode trunk
SW-B(config-if-range)#switchport trunk native vlan 99
SW-B(config-if-range)#switchport trunk allowed vlan 1,21-23
SW-B(config-if-range)#channel-group 1 mode passive //mode passive because “SwitchA controlling activation”
SW-B(config-if-range)#channel-protocol lacp
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#end

———————————————————------------------------------------------








출처 : http://www.certprepare.com


Name
Password
Homepage
Secret